$re = '/(?<!"\s)#([0-9\p{L}]+)(?=[\s,!?.\n][^"]|$)/m';
$str = 'I enjoy #action movies! #Action
movies are #cool.
Color #000000; #ffffff; work fine
<div style=" #something "> - works
#action " - works
" #action - doesn\'t work
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);