using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\){(.*?)(?<!\\)}";
string input = @"dont want \{dont want 'want\} this', 'want this, je m\'appelle Robert', d{ont want\}
'dont want' {hello} {truc} {blabla qsddqs}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}