$re = '/(?<!\\\\){(.*?)(?<!\\\\)}/';
$str = 'dont want \\{dont want \'want\\} this\', \'want this, je m\\\'appelle Robert\', d{ont want\\}
\'dont want\' {hello} {truc} {blabla qsddqs}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);