import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\)\\{(.*?)(?<!\\\\)\\}";
final String string = "dont want \\{dont want 'want\\} this', 'want this, je m\\'appelle Robert', d{ont want\\} \n"
+ "'dont want' {hello} {truc} {blabla qsddqs}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}