re = /(?<!\\){(.*?)(?<!\\)}/
str = 'dont want \\{dont want \'want\\} this\', \'want this, je m\\\'appelle Robert\', d{ont want\\}
\'dont want\' {hello} {truc} {blabla qsddqs}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end