#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<h4>[\w\W]+?<\/p>(?=$)"
Local $sString = "<h4>Headline 1</h4>" & @CRLF & _
"<p>Content 1</p>" & @CRLF & _
"<h4>Headline 2</h4>" & @CRLF & _
"<p>Content 2</p>" & @CRLF & _
"<h4>Headline 3</h4>" & @CRLF & _
"<p>Content 3</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")