re = /<h4>[\w\W]+?<\/p>(?=$)/m
str = '<h4>Headline 1</h4>
<p>Content 1</p>
<h4>Headline 2</h4>
<p>Content 2</p>
<h4>Headline 3</h4>
<p>Content 3</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end