import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h4>[\\w\\W]+?<\\/p>(?=$)";
final String string = "<h4>Headline 1</h4>\n"
+ "<p>Content 1</p>\n"
+ "<h4>Headline 2</h4>\n"
+ "<p>Content 2</p>\n"
+ "<h4>Headline 3</h4>\n"
+ "<p>Content 3</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}