using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h4>[\w\W]+?<\/p>(?=$)";
string input = @"<h4>Headline 1</h4>
<p>Content 1</p>
<h4>Headline 2</h4>
<p>Content 2</p>
<h4>Headline 3</h4>
<p>Content 3</p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}