use strict;
my $str = 'Amnuel Pavel
Andersen Hans Christien';
my $regex = qr/(w)/mp;
my $subst = '{1}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";