using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<value>[+-]?([$%C$€]|C$)*(?:\d*\.?\d+)([mkC%€$£]|C\$)*)";
string input = @" . . . .45
.45
---,,,... 1.123
---,,,... 56€
. . . $.456 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}