package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<value>[+-]?([$%C$€]|C$)*(?:\d*\.?\d+)([mkC%€$£]|C\$)*)`)
var str = ` . . . .45
.45
---,,,... 1.123
---,,,... 56€
. . . $.456 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}