$re = '/(?<value>[+-]?([$%C$€]|C$)*(?:\d*\.?\d+)([mkC%€$£]|C\$)*)/m';
$str = ' . . . .45
.45
---,,,... 1.123
---,,,... 56€
. . . $.456 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);