re = /(?<value>[+-]?([$%C$€]|C$)*(?:\d*\.?\d+)([mkC%€$£]|C\$)*)/m
str = ' . . . .45
.45
---,,,... 1.123
---,,,... 56€
. . . $.456 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end