#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?<=\\n)((?:(?!\\n).)*?)(?=\\nstar)"
Local $sString = "\n\n\nclone\nstar\n\n\n\n\nbrain\nstar\n\n\n\n\ncalculator\nstar\n\n\n\n\nadding machine\nstar\n\n\n\n\nartificial intelligence\nstar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")