$re = '/(?<=\\\\n)((?:(?!\\\\n).)*?)(?=\\\\nstar)/im';
$str = '\\n\\n\\nclone\\nstar\\n\\n\\n\\n\\nbrain\\nstar\\n\\n\\n\\n\\ncalculator\\nstar\\n\\n\\n\\n\\nadding machine\\nstar\\n\\n\\n\\n\\nartificial intelligence\\nstar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);