using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\\n)((?:(?!\\n).)*?)(?=\\nstar)";
string input = @"\n\n\nclone\nstar\n\n\n\n\nbrain\nstar\n\n\n\n\ncalculator\nstar\n\n\n\n\nadding machine\nstar\n\n\n\n\nartificial intelligence\nstar";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}