re = /(?<=\\n)((?:(?!\\n).)*?)(?=\\nstar)/im
str = '\\n\\n\\nclone\\nstar\\n\\n\\n\\n\\nbrain\\nstar\\n\\n\\n\\n\\ncalculator\\nstar\\n\\n\\n\\n\\nadding machine\\nstar\\n\\n\\n\\n\\nartificial intelligence\\nstar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end