import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bCFV\\[1161170\\](?:(?!\\[UNIQUE\\]|\\bCFV\\[1161170\\]).)*\\[VALUE\\]";
final String string = "CFV[1161170][UNIQUE][VALUE] CFV[1161170][5pGKucpYSQ][VALUE] CFV[1161170][jk9Gh79SK2z][VALUE]\n\n"
+ "CFV[1161170][UNIQUE][jk9Gh79SK2z][VALUE]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}