import Foundation
let pattern = #"\bCFV\[1161170\](?:(?!\[UNIQUE\]|\bCFV\[1161170\]).)*\[VALUE\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
CFV[1161170][UNIQUE][VALUE] CFV[1161170][5pGKucpYSQ][VALUE] CFV[1161170][jk9Gh79SK2z][VALUE]
CFV[1161170][UNIQUE][jk9Gh79SK2z][VALUE]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)