import re
regex = re.compile(r"\bCFV\[1161170\](?:(?!\[UNIQUE\]|\bCFV\[1161170\]).)*\[VALUE\]")
test_str = ("CFV[1161170][UNIQUE][VALUE] CFV[1161170][5pGKucpYSQ][VALUE] CFV[1161170][jk9Gh79SK2z][VALUE]\n\n"
"CFV[1161170][UNIQUE][jk9Gh79SK2z][VALUE]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")