#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\s*\{{2}funcA(ka|)\s*\|\s*([^}]*)\s*\}{2}\s*|)\{{2}funcB\s*\|\s*([^\}]*)\s*\}{2}\s*"
Local $sString = "{{funcB|param1}}" & @CRLF & _
"*some string*" & @CRLF & _
"{{funcA|param2}}" & @CRLF & _
"{{funcB|param3}}" & @CRLF & _
"*some string2*" & @CRLF & _
" " & @CRLF & _
"{{funcB|param4}}" & @CRLF & _
"*some string3*" & @CRLF & _
"{{funcAka|param5}}" & @CRLF & _
"{{funcB|param6}}" & @CRLF & _
"*some string4*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")