const regex = new RegExp('(?i)(\\s*\\{{2}funcA(ka|)\\s*\\|\\s*([^}]*)\\s*\\}{2}\\s*|)\\{{2}funcB\\s*\\|\\s*([^\\}]*)\\s*\\}{2}\\s*', 'g')
const str = `{{funcB|param1}}
*some string*
{{funcA|param2}}
{{funcB|param3}}
*some string2*
{{funcB|param4}}
*some string3*
{{funcAka|param5}}
{{funcB|param6}}
*some string4*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}