import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(\\s*\\{{2}funcA(ka|)\\s*\\|\\s*([^\\}]*)\\s*\\}{2}\\s*|)\\{{2}funcB\\s*\\|\\s*([^\\}]*)\\s*\\}{2}\\s*";
final String string = "{{funcB|param1}}\n"
+ "*some string*\n"
+ "{{funcA|param2}}\n"
+ "{{funcB|param3}}\n"
+ "*some string2*\n"
+ " \n"
+ "{{funcB|param4}}\n"
+ "*some string3*\n"
+ "{{funcAka|param5}}\n"
+ "{{funcB|param6}}\n"
+ "*some string4*";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}