import re
regex = re.compile(r"(?i)(\s*\{{2}funcA(ka|)\s*\|\s*([^}]*)\s*\}{2}\s*|)\{{2}funcB\s*\|\s*([^\}]*)\s*\}{2}\s*")
test_str = ("{{funcB|param1}}\n"
"*some string*\n"
"{{funcA|param2}}\n"
"{{funcB|param3}}\n"
"*some string2*\n"
" \n"
"{{funcB|param4}}\n"
"*some string3*\n"
"{{funcAka|param5}}\n"
"{{funcB|param6}}\n"
"*some string4*")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")