#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[a-zA-Z]\d([a-zA-Z]|\d)(.([a-zA-Z]|\d){1,4})?"
Local $sString = "L89.141 – Pressure ulcer of left lower back, stage 1" & @CRLF & _
"L89.142 – Pressure ulcer of left lower back, stage 2" & @CRLF & _
"L89.143 – Pressure ulcer of left lower back, stage 3" & @CRLF & _
"L89.144 – Pressure ulcer of left lower back, stage 4" & @CRLF & _
"L89.149 – Pressure ulcer of left lower back, unspecified stage" & @CRLF & _
"L89.151 – Pressure ulcer of sacral region, stage 1" & @CRLF & _
"L89.152 – Pressure ulcer of sacral region, stage 2" & @CRLF & _
"" & @CRLF & _
"A12.123a" & @CRLF & _
"123.1" & @CRLF & _
"B23" & @CRLF & _
"B12." & @CRLF & _
"" & @CRLF & _
"B12.321assdf" & @CRLF & _
"12B23.234a ds"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")