$re = '/[a-zA-Z]\d([a-zA-Z]|\d)(.([a-zA-Z]|\d){1,4})?/';
$str = 'L89.141 – Pressure ulcer of left lower back, stage 1
L89.142 – Pressure ulcer of left lower back, stage 2
L89.143 – Pressure ulcer of left lower back, stage 3
L89.144 – Pressure ulcer of left lower back, stage 4
L89.149 – Pressure ulcer of left lower back, unspecified stage
L89.151 – Pressure ulcer of sacral region, stage 1
L89.152 – Pressure ulcer of sacral region, stage 2
A12.123a
123.1
B23
B12.
B12.321assdf
12B23.234a ds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);