import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]\\d([a-zA-Z]|\\d)(.([a-zA-Z]|\\d){1,4})?";
final String string = "L89.141 – Pressure ulcer of left lower back, stage 1\n"
+ "L89.142 – Pressure ulcer of left lower back, stage 2\n"
+ "L89.143 – Pressure ulcer of left lower back, stage 3\n"
+ "L89.144 – Pressure ulcer of left lower back, stage 4\n"
+ "L89.149 – Pressure ulcer of left lower back, unspecified stage\n"
+ "L89.151 – Pressure ulcer of sacral region, stage 1\n"
+ "L89.152 – Pressure ulcer of sacral region, stage 2\n\n"
+ "A12.123a\n"
+ "123.1\n"
+ "B23\n"
+ "B12.\n\n"
+ "B12.321assdf\n"
+ "12B23.234a ds";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}