#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""(?:[ \w]*)+([\n\r])+(?:[ \w]*)+""
Local $sString = "<main>" & @CRLF & _
"<head/><body><note text="Load"> " & @CRLF & _
"<note text="2 Newlines at the end of this " & @CRLF & _
"" & @CRLF & _
"newline"/>" & @CRLF & _
"</body>" & @CRLF & _
"</main>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")