// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""(?:[ \w]*)+([\n\r])+(?:[ \w]*)+""#).unwrap();
let string = "<main>
<head/><body><note text=\"Load\">
<note text=\"2 Newlines at the end of this
newline\"/>
</body>
</main>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}