import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(?:[ \\w]*)+([\\n\\r])+(?:[ \\w]*)+\"";
final String string = "<main>\n"
+ "<head/><body><note text=\"Load\"> \n"
+ "<note text=\"2 Newlines at the end of this \n\n"
+ "newline\"/>\n"
+ "</body>\n"
+ "</main>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}