#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https?:\/\/(www\.)?instagram\.com\/([^\/]\w+)"
Local $sString = "https://plus.google.com/u/0/+Username" & @CRLF & _
"https://plus.google.com/u/2/Username/posts" & @CRLF & _
"" & @CRLF & _
"https?:\/\/plus\.google\.com\/([^\/]*)" & @CRLF & _
"#хватает только "u"" & @CRLF & _
"" & @CRLF & _
"https?:\/\/(www\.)?instagram\.com\/([^\/].+)" & @CRLF & _
"#instagram режет: "username/" - как убрать в конце "/" ?" & @CRLF & _
"" & @CRLF & _
"https://instagram.com/username/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")