package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/(www\.)?instagram\.com\/([^\/]\w+)`)
var str = `https://plus.google.com/u/0/+Username
https://plus.google.com/u/2/Username/posts
https?:\/\/plus\.google\.com\/([^\/]*)
#хватает только "u"
https?:\/\/(www\.)?instagram\.com\/([^\/].+)
#instagram режет: "username/" - как убрать в конце "/" ?
https://instagram.com/username/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}