import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/(www\\.)?instagram\\.com\\/([^\\/]\\w+)";
final String string = "https://plus.google.com/u/0/+Username\n"
+ "https://plus.google.com/u/2/Username/posts\n\n"
+ "https?:\\/\\/plus\\.google\\.com\\/([^\\/]*)\n"
+ "#хватает только \"u\"\n\n"
+ "https?:\\/\\/(www\\.)?instagram\\.com\\/([^\\/].+)\n"
+ "#instagram режет: \"username/\" - как убрать в конце \"/\" ?\n\n"
+ "https://instagram.com/username/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}