re = /https?:\/\/(www\.)?instagram\.com\/([^\/]\w+)/
str = 'https://plus.google.com/u/0/+Username
https://plus.google.com/u/2/Username/posts
https?:\\/\\/plus\\.google\\.com\\/([^\\/]*)
#хватает только "u"
https?:\\/\\/(www\\.)?instagram\\.com\\/([^\\/].+)
#instagram режет: "username/" - как убрать в конце "/" ?
https://instagram.com/username/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end