#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\S+) (?!.*\1$).*"
Local $sString = "10.10.10.10 | computer name | John Doe> some text username on 11.11.11.11" & @CRLF & _
"" & @CRLF & _
"10.10.10.10 | computer name | John Doe> some text username on 10.10.10.10" & @CRLF & _
"" & @CRLF & _
"255.255.255.255 | computer name | John Doe> some text username on 255.255.255.255" & @CRLF & _
"" & @CRLF & _
"255.255.255.244 | computer name | John Doe> some text username on 255.255.255.255" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")