import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+) (?!.*\\1$).*";
final String string = "10.10.10.10 | computer name | John Doe> some text username on 11.11.11.11\n\n"
+ "10.10.10.10 | computer name | John Doe> some text username on 10.10.10.10\n\n"
+ "255.255.255.255 | computer name | John Doe> some text username on 255.255.255.255\n\n"
+ "255.255.255.244 | computer name | John Doe> some text username on 255.255.255.255\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}