use strict;
my $str = '10.10.10.10 | computer name | John Doe> some text username on 11.11.11.11
10.10.10.10 | computer name | John Doe> some text username on 10.10.10.10
255.255.255.255 | computer name | John Doe> some text username on 255.255.255.255
255.255.255.244 | computer name | John Doe> some text username on 255.255.255.255
';
my $regex = qr/^(\S+) (?!.*\1$).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}