$re = '/^(\S+) (?!.*\1$).*/m';
$str = '10.10.10.10 | computer name | John Doe> some text username on 11.11.11.11
10.10.10.10 | computer name | John Doe> some text username on 10.10.10.10
255.255.255.255 | computer name | John Doe> some text username on 255.255.255.255
255.255.255.244 | computer name | John Doe> some text username on 255.255.255.255
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);