using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(\d[\d.,]*)\s?(cm|m|mm|dm|verstellbar)\b.*$";
string input = @"Ledergürtel 100cm";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}