package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*?(\d[\d.,]*)\s?(cm|m|mm|dm|verstellbar)\b.*$`)
var str = `Ledergürtel 100cm`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}