$re = '/^.*?(\d[\d.,]*)\s?(cm|m|mm|dm|verstellbar)\b.*$/';
$str = 'Ledergürtel 100cm';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);