re = /^.*?(\d[\d.,]*)\s?(cm|m|mm|dm|verstellbar)\b.*$/
str = 'Ledergürtel 100cm'
# Print the match result
str.match(re) do |match|
puts match.to_s
end