package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+\.?\d*`)
var str = `123123ff
0.123123ff
ss123123ff
sadasd
12313
123gg232
1.1ss
0.122dddd
1ee
dd23.2fdf
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}