$re = '/^\d+\.?\d*/m';
$str = '123123ff
0.123123ff
ss123123ff
sadasd
12313
123gg232
1.1ss
0.122dddd
1ee
dd23.2fdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);