const regex = /^\d+\.?\d*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\.?\\d*', 'gm')
const str = `123123ff
0.123123ff
ss123123ff
sadasd
12313
123gg232
1.1ss
0.122dddd
1ee
dd23.2fdf
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}