re = /^\d+\.?\d*/m
str = '123123ff
0.123123ff
ss123123ff
sadasd
12313
123gg232
1.1ss
0.122dddd
1ee
dd23.2fdf
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end