using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([k,K]ıdem [t,T]azminatı )(?![ö,Ö]deme)";
string input = @"- Amortisman ve İtfa Payları
- Kıdem Tazminatı Karşılığı
- Kıdem tazminatı ödemesi";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}