import re
regex = re.compile(r"([k,K]ıdem [t,T]azminatı )(?![ö,Ö]deme)")
test_str = ("- Amortisman ve İtfa Payları\n"
"- Kıdem Tazminatı Karşılığı\n"
"- Kıdem tazminatı ödemesi")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")