re = /([k,K]ıdem [t,T]azminatı )(?![ö,Ö]deme)/
str = '- Amortisman ve İtfa Payları
- Kıdem Tazminatı Karşılığı
- Kıdem tazminatı ödemesi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end